تقنية

لماذا يمنع Android 14 تثبيت التطبيق؟

سيكون Android 13 شيئًا من الماضي لأن Google تريد إطلاق Android 14 في الأشهر القليلة المقبلة. سيتوفر نظام التشغيل الجديد على أحدث الهواتف الذكية. وبالمثل ، سنحصل على معاينة أولى في الأشهر القليلة القادمة.

في الوقت الحالي ، تحتاج Google إلى إنهاء عملها قبل إطلاق نظام التشغيل الجديد علنًا. لن يسمح لك Android 14 بتثبيت التطبيقات التي تستهدف إصدارات SDK السابقة. باختصار ، لن يُسمح بتثبيت التطبيقات القديمة التي تستهدف Android 13 أو أقل على هاتفك.

9to5Google يمكن التعرف على الاختلاف من خلال تعديل التعليمات البرمجية. ولقرص الكود متطلبات API صارمة لتثبيت التطبيق. المنشور يقول ذلك.

حظر تثبيت التطبيقات التي تستهدف إصدار SDK أقل إذا تم تمكين الحد الأدنى من فرض إصدار SDK القابل للتثبيت. سيساعد في تحسين أمان هواتف Android. علاوة على ذلك ، سيزيد من الخصوصية لأن البرامج الضارة يمكن أن تؤثر على إصدارات SDK الأقدم “.

وبالتالي ، لن تتمكن من تثبيت التطبيقات التي تستهدف إصدارات Android السابقة.

سيحظر Android 14 تثبيت التطبيقات لإصدارات SDK السابقة:

في البداية ، سيمنع نظام Android 14 الجديد تثبيت إصدار SDK الأقدم على هاتفك. ومع ذلك ، بمرور الوقت ، سيرتفع الحد الأدنى من المتطلبات إلى Android 6.

لحسن الحظ ، لا يزال بإمكانك جعل الأشياء تعمل من أجلك. يمكنك تثبيت التطبيقات القديمة باستخدام العلم الجديد. العلم سيتجاوز الظروف. سيتعين عليك استخدام غلاف أوامر ADB لتمكين العلم.

الهدف الرئيسي هو منع البرامج الضارة من الانتشار ومضايقة المستخدمين. في السنوات الأخيرة ، قام موزعو البرامج الضارة بتضليل المستخدمين بتقنيات أكثر دقة. يقومون بتنزيل التطبيقات من خلال توفير تعليمات سليمة وصحيحة.

الأهم من ذلك ، سيكون الاستغلال أكثر صعوبة عندما يمنع نظام التشغيل تثبيت تطبيق معين. هذا ليس مستغربا.

ستمنح Google بالتأكيد المطورين الوقت لتحديث التطبيقات إلى إصدار SDK أحدث. سيتعين على المطورين الرجوع إلى إصدار أقدم من تطبيقاتهم إلى Android 14 أو إصدار أحدث للنشر. حاليًا ، لا تفي تطبيقات التحميل الجانبي بجميع هذه المتطلبات.

مقالات ذات صلة

اترك تعليقاً

لن يتم نشر عنوان بريدك الإلكتروني. الحقول الإلزامية مشار إليها بـ *

زر الذهاب إلى الأعلى